Main Forum

How to increase FPS when running FTB on a laptop with two graphics cards.

4 replies
Muah_dib aAdmin
454 posts
+58 likes
+82 Points
Admins
Whitelisted
If you run FTB on a laptop with two graphics adapters,
this normaly means that you're probably running FTB with your CPU integrated graphics, not the dedicated (Nvidia) one.

Right clicking the FTB launcher and selecting the Nvidia GPU doesn't work.
You need to manually add the "javaw.exe" file from your Java installation to the 3D settings tab in the nvidia control panel.
You can find this file most of the time in "C: \Program Files\Java\JRE\bin" or "C:\Program Files\Java\jre7\bin", depending java version.

The way you do this step by step is:

1- Right click your desktop area and select "Nvidia control panel"
2- Select 3D settings
3- Select program setings tab.
4- Click the Add button and search and select the file mentioned.
5- Select Nvidia processor
6- Hit the Aply button and close Nvidia control panel.


All you have to do after this is run your FTB as you normaly do and enjoy your increased FPS.


I hope this helps.
Muah_dib
Posted Aug 9, 13 · OP · Last edited Aug 20, 13
+1  likes
1
 likes

0 Down Voted

28 posts
0 likes
Untagged users
Is this the process the same from AMD graphics cards?
Posted Aug 9, 13
0  likes
Muah_dib aAdmin
454 posts
+58 likes
+82 Points
Admins
Whitelisted
I'm not sure on how to do it with AMD graphic cards, since I got a laptop with a Nvidia card.
But if AMD has a similer control panel app, then yes, else you will be runing the game with your CPU integrated card.

The problem is not the graphic cards but windows always chosing the primary graphic card, in this case the CPU integrated card, to run Java apps, even if they are 3D apps like minecraft. Don't ask me why windows does that cause i don't know.

Ps. Doing this process to vanilla minecraft (selecting minecraft.exe instead of javaw.exe), will only work for vanilla minecraft, not FTB.

Hope that helps.

cheers
Posted Aug 9, 13 · OP
0  likes
eDilettante Junior ModGrumpy
34 posts
+6 likes
+272 Points
Whitelisted
If you're also using Optifine and have problems with blocks flickering, you may need to adjust the nVidia settings for javaw.exe in the same place above - setting either or both of the following seem to do the trick:
Threaded Optimisation - set to 'Off'
Vertical Sync - set to 'Force On'
Posted Aug 9, 13
0  likes
5 posts
0 likes
Untagged users
Optifine with all animations off does wonders.
Posted Jul 10, 14
0  likes
Top Posters
454 Posts
Muah_dib Admin
439 Posts
NinjaDjay Admin
172 Posts
billynap1974 AdminPlatinum
149 Posts
enisledlady AdminGrumpy
102 Posts
tibblaye Grumpy
Announcement of